summaryrefslogtreecommitdiffstats
path: root/codemaker/test/javamaker/makefile.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /codemaker/test/javamaker/makefile.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'codemaker/test/javamaker/makefile.mk')
-rw-r--r--codemaker/test/javamaker/makefile.mk32
1 files changed, 32 insertions, 0 deletions
diff --git a/codemaker/test/javamaker/makefile.mk b/codemaker/test/javamaker/makefile.mk
new file mode 100644
index 000000000..643bb7902
--- /dev/null
+++ b/codemaker/test/javamaker/makefile.mk
@@ -0,0 +1,32 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+PRJ := ..$/..
+PRJNAME := codemaker
+TARGET := test_codemaker_javamaker
+
+PACKAGE := test$/codemaker$/javamaker
+JAVATESTFILES := Test.java
+IDLTESTFILES := types.idl
+JARFILES := juh.jar jurt.jar ridl.jar
+
+JAVAMAKER = $(BIN)$/javamaker$(EXECPOST)
+
+.INCLUDE: javaunittest.mk
+
+$(MISC)$/$(TARGET).javamaker.flag: $(BIN)$/javamaker$(EXECPOST)