summaryrefslogtreecommitdiffstats
path: root/codemaker/test/javamaker/makefile.mk
diff options
context:
space:
mode:
Diffstat (limited to 'codemaker/test/javamaker/makefile.mk')
-rw-r--r--codemaker/test/javamaker/makefile.mk32
1 files changed, 32 insertions, 0 deletions
diff --git a/codemaker/test/javamaker/makefile.mk b/codemaker/test/javamaker/makefile.mk
new file mode 100644
index 000000000..643bb7902
--- /dev/null
+++ b/codemaker/test/javamaker/makefile.mk
@@ -0,0 +1,32 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+PRJ := ..$/..
+PRJNAME := codemaker
+TARGET := test_codemaker_javamaker
+
+PACKAGE := test$/codemaker$/javamaker
+JAVATESTFILES := Test.java
+IDLTESTFILES := types.idl
+JARFILES := juh.jar jurt.jar ridl.jar
+
+JAVAMAKER = $(BIN)$/javamaker$(EXECPOST)
+
+.INCLUDE: javaunittest.mk
+
+$(MISC)$/$(TARGET).javamaker.flag: $(BIN)$/javamaker$(EXECPOST)