summaryrefslogtreecommitdiffstats
path: root/onlineupdate/qa/single_step
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /onlineupdate/qa/single_step
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'onlineupdate/qa/single_step')
-rw-r--r--onlineupdate/qa/single_step/Makefile27
-rw-r--r--onlineupdate/qa/single_step/complete_signed.marbin0 -> 2025 bytes
-rw-r--r--onlineupdate/qa/single_step/incremental_signed.marbin0 -> 730 bytes
-rw-r--r--onlineupdate/qa/single_step/single_step.zipbin0 -> 1271 bytes
4 files changed, 27 insertions, 0 deletions
diff --git a/onlineupdate/qa/single_step/Makefile b/onlineupdate/qa/single_step/Makefile
new file mode 100644
index 000000000..f303992ba
--- /dev/null
+++ b/onlineupdate/qa/single_step/Makefile
@@ -0,0 +1,27 @@
+gb_Side := host
+include ../../../config_host.mk
+
+UPDATER_DIR := $(WORKDIR)/updater/single_step
+
+all : call
+
+unpack:
+ @echo "Unpacking the updater test project"
+ @rm -r $(UPDATER_DIR) || true
+ @mkdir -p $(UPDATER_DIR)
+ @unzip single_step.zip -d $(WORKDIR)/updater > /dev/null
+ @mkdir -p $(UPDATER_DIR)/patch
+
+call-complete: unpack
+ @echo "Update the test project"
+ @cp complete_signed.mar $(UPDATER_DIR)/patch/update.mar
+ @$(INSTDIR)/program/updater $(UPDATER_DIR)/patch $(UPDATER_DIR) $(UPDATER_DIR) 0
+
+call-incremental: unpack
+ @echo "Update the test project"
+ @cp incremental_signed.mar $(UPDATER_DIR)/patch/update.mar
+ @$(INSTDIR)/program/updater $(UPDATER_DIR)/patch $(UPDATER_DIR) $(UPDATER_DIR) 0
+
+call-gdb: unpack
+ @cp incremental_signed.mar $(UPDATER_DIR)/patch/update.mar
+ gdb --args $(INSTDIR)/program/updater $(UPDATER_DIR)/patch $(UPDATER_DIR) $(UPDATER_DIR) 0
diff --git a/onlineupdate/qa/single_step/complete_signed.mar b/onlineupdate/qa/single_step/complete_signed.mar
new file mode 100644
index 000000000..7b0631dd3
--- /dev/null
+++ b/onlineupdate/qa/single_step/complete_signed.mar
Binary files differ
diff --git a/onlineupdate/qa/single_step/incremental_signed.mar b/onlineupdate/qa/single_step/incremental_signed.mar
new file mode 100644
index 000000000..6ec6e7a1a
--- /dev/null
+++ b/onlineupdate/qa/single_step/incremental_signed.mar
Binary files differ
diff --git a/onlineupdate/qa/single_step/single_step.zip b/onlineupdate/qa/single_step/single_step.zip
new file mode 100644
index 000000000..823a590e0
--- /dev/null
+++ b/onlineupdate/qa/single_step/single_step.zip
Binary files differ