summaryrefslogtreecommitdiffstats
path: root/sal/Library_lo-bootstrap.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /sal/Library_lo-bootstrap.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sal/Library_lo-bootstrap.mk')
-rw-r--r--sal/Library_lo-bootstrap.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/sal/Library_lo-bootstrap.mk b/sal/Library_lo-bootstrap.mk
new file mode 100644
index 000000000..3dc4bf9df
--- /dev/null
+++ b/sal/Library_lo-bootstrap.mk
@@ -0,0 +1,31 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,lo-bootstrap))
+
+# We explicitly *don't* want gb_STDLIBS to be linked here
+$(eval $(call gb_Library_disable_standard_system_libs,lo-bootstrap))
+
+$(eval $(call gb_Library_add_libs,lo-bootstrap,\
+ -llog \
+ -landroid \
+))
+
+$(eval $(call gb_Library_add_cobjects,lo-bootstrap,\
+ sal/android/libreofficekit-jni \
+ sal/android/lo-bootstrap \
+))
+
+$(eval $(call gb_Library_set_include,lo-bootstrap,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/sal/inc \
+))
+
+# vim: set noet sw=4 ts=4: