summaryrefslogtreecommitdiffstats
path: root/sal/Library_lo-bootstrap.mk
diff options
context:
space:
mode:
Diffstat (limited to 'sal/Library_lo-bootstrap.mk')
-rw-r--r--sal/Library_lo-bootstrap.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/sal/Library_lo-bootstrap.mk b/sal/Library_lo-bootstrap.mk
new file mode 100644
index 000000000..3dc4bf9df
--- /dev/null
+++ b/sal/Library_lo-bootstrap.mk
@@ -0,0 +1,31 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,lo-bootstrap))
+
+# We explicitly *don't* want gb_STDLIBS to be linked here
+$(eval $(call gb_Library_disable_standard_system_libs,lo-bootstrap))
+
+$(eval $(call gb_Library_add_libs,lo-bootstrap,\
+ -llog \
+ -landroid \
+))
+
+$(eval $(call gb_Library_add_cobjects,lo-bootstrap,\
+ sal/android/libreofficekit-jni \
+ sal/android/lo-bootstrap \
+))
+
+$(eval $(call gb_Library_set_include,lo-bootstrap,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/sal/inc \
+))
+
+# vim: set noet sw=4 ts=4: