summaryrefslogtreecommitdiffstats
path: root/unoil/CliUnoApi_oootypes.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /unoil/CliUnoApi_oootypes.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'unoil/CliUnoApi_oootypes.mk')
-rw-r--r--unoil/CliUnoApi_oootypes.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/unoil/CliUnoApi_oootypes.mk b/unoil/CliUnoApi_oootypes.mk
new file mode 100644
index 000000000..69d0a128f
--- /dev/null
+++ b/unoil/CliUnoApi_oootypes.mk
@@ -0,0 +1,29 @@
+
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+include $(SRCDIR)/unoil/climaker/version.txt
+
+$(eval $(call gb_CliUnoApi_CliUnoApi,cli_oootypes))
+
+$(eval $(call gb_CliUnoApi_set_assembly_version,cli_oootypes,$(CLI_OOOTYPES_NEW_VERSION)))
+
+$(eval $(call gb_CliUnoApi_set_configfile,cli_oootypes,unoil/climaker/cli_oootypes_config,unoil/climaker/version.txt))
+
+$(eval $(call gb_CliUnoApi_set_keyfile,cli_oootypes,$(SRCDIR)/cli_ure/source/cliuno.snk))
+
+$(eval $(call gb_CliUnoApi_set_policy,cli_oootypes,$(CLI_OOOTYPES_POLICY_ASSEMBLY),$(CLI_OOOTYPES_POLICY_VERSION)))
+
+$(eval $(call gb_CliUnoApi_wrap_api,cli_oootypes,offapi))
+
+$(eval $(call gb_CliUnoApi_use_api,cli_oootypes,udkapi))
+
+$(eval $(call gb_CliUnoApi_use_assembly,cli_oootypes,cli_uretypes))
+
+# vim: set noet sw=4 ts=4: