summaryrefslogtreecommitdiffstats
path: root/unoil/CustomTarget_javamaker.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /unoil/CustomTarget_javamaker.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'unoil/CustomTarget_javamaker.mk')
-rw-r--r--unoil/CustomTarget_javamaker.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/unoil/CustomTarget_javamaker.mk b/unoil/CustomTarget_javamaker.mk
new file mode 100644
index 000000000..97793d519
--- /dev/null
+++ b/unoil/CustomTarget_javamaker.mk
@@ -0,0 +1,31 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,unoil/javamaker))
+
+unoil_JAVADIR := $(call gb_CustomTarget_get_workdir,unoil/javamaker)
+
+$(call gb_CustomTarget_get_target,unoil/javamaker) : $(unoil_JAVADIR)/done
+
+$(unoil_JAVADIR)/done : \
+ $(call gb_UnoApi_get_target,offapi) \
+ $(call gb_UnoApi_get_target,udkapi) \
+ $(call gb_Executable_get_runtime_dependencies,javamaker) \
+ | $(unoil_JAVADIR)/.dir
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),JVM,1)
+ $(call gb_Trace_StartRange,$(subst $(WORKDIR)/,,$@),JVM)
+ $(call gb_Helper_abbreviate_dirs, \
+ rm -r $(unoil_JAVADIR) && \
+ $(call gb_Helper_execute,javamaker -O$(unoil_JAVADIR) \
+ $(call gb_UnoApi_get_target,offapi) \
+ -X$(call gb_UnoApi_get_target,udkapi)) && \
+ touch $@)
+ $(call gb_Trace_EndRange,$(subst $(WORKDIR)/,,$@),JVM)
+
+# vim:set shiftwidth=4 tabstop=4 noexpandtab: