summaryrefslogtreecommitdiffstats
path: root/uitest/packaging/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'uitest/packaging/Makefile')
-rw-r--r--uitest/packaging/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/uitest/packaging/Makefile b/uitest/packaging/Makefile
new file mode 100644
index 000000000..af63c946e
--- /dev/null
+++ b/uitest/packaging/Makefile
@@ -0,0 +1,16 @@
+all:
+ @echo "Packaging the libreoffice-connection code"
+ @mkdir -p libreoffice
+ @cp ../libreoffice/connection.py libreoffice/.
+ @touch libreoffice/__init__.py
+ @python3 setup.py sdist
+
+clean:
+ rm -r dist/
+ rm -r libreoffice_connection.egg-info/
+ rm -r libreoffice/
+ rm -r build/
+
+publish:
+ @echo "Uploading the release to pypi"
+ twine upload dist/*