summaryrefslogtreecommitdiffstats
path: root/uitest/packaging
diff options
context:
space:
mode:
Diffstat (limited to 'uitest/packaging')
-rw-r--r--uitest/packaging/Makefile16
-rw-r--r--uitest/packaging/README.rst4
-rw-r--r--uitest/packaging/setup.cfg0
-rw-r--r--uitest/packaging/setup.py34
4 files changed, 54 insertions, 0 deletions
diff --git a/uitest/packaging/Makefile b/uitest/packaging/Makefile
new file mode 100644
index 000000000..af63c946e
--- /dev/null
+++ b/uitest/packaging/Makefile
@@ -0,0 +1,16 @@
+all:
+ @echo "Packaging the libreoffice-connection code"
+ @mkdir -p libreoffice
+ @cp ../libreoffice/connection.py libreoffice/.
+ @touch libreoffice/__init__.py
+ @python3 setup.py sdist
+
+clean:
+ rm -r dist/
+ rm -r libreoffice_connection.egg-info/
+ rm -r libreoffice/
+ rm -r build/
+
+publish:
+ @echo "Uploading the release to pypi"
+ twine upload dist/*
diff --git a/uitest/packaging/README.rst b/uitest/packaging/README.rst
new file mode 100644
index 000000000..45d8716f6
--- /dev/null
+++ b/uitest/packaging/README.rst
@@ -0,0 +1,4 @@
+Connection code for LibreOffice's pyUNO
+=======================================
+
+This code allows out-of-process communication with a LibreOffice instance. The instance can either be started by the script or a connection to a running LibreOffice instance. The code contains several safety checks for hanging and crashed LibreOffice instances.
diff --git a/uitest/packaging/setup.cfg b/uitest/packaging/setup.cfg
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/uitest/packaging/setup.cfg
diff --git a/uitest/packaging/setup.py b/uitest/packaging/setup.py
new file mode 100644
index 000000000..9aa32054c
--- /dev/null
+++ b/uitest/packaging/setup.py
@@ -0,0 +1,34 @@
+from setuptools import setup, find_packages
+from codecs import open
+from os import path
+
+here = path.abspath(path.dirname(__file__))
+
+# Get the long description from the README file
+with open(path.join(here, 'README.rst'), encoding='utf-8') as f:
+ long_description = f.read()
+
+setup(
+ name="libreoffice-connection",
+ version="0.0.1",
+ description="Connection code for LibreOffice's pyUNO",
+ long_description=long_description,
+ url="http://www.libreoffice.org",
+ author="The LibreOffice developers",
+ author_email="libreoffice@lists.freedesktop.org",
+ license="MPL2",
+ classifiers=[
+ "Development Status :: 3 - Alpha",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: Mozilla Public License 2.0 (MPL 2.0)",
+ "Programming Language :: Python :: 3.2",
+ "Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
+ "Topic :: Office/Business :: Office Suites",
+ "Topic :: Software Development :: Libraries",
+ ],
+ keywords="office automation",
+ packages=find_packages(),
+)