summaryrefslogtreecommitdiffstats
path: root/docs/reference
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:39:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:39:48 +0000
commit3ade071f273aaa973e44bf95d6b1d4913a18f03b (patch)
treee2f99d267ae18427645404f215b984afbe73098d /docs/reference
parentInitial commit. (diff)
downloadnautilus-3ade071f273aaa973e44bf95d6b1d4913a18f03b.tar.xz
nautilus-3ade071f273aaa973e44bf95d6b1d4913a18f03b.zip
Adding upstream version 43.2.upstream/43.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'docs/reference')
-rw-r--r--docs/reference/meson.build31
-rw-r--r--docs/reference/nautilus.toml.in22
-rw-r--r--docs/reference/urlmap.js9
3 files changed, 62 insertions, 0 deletions
diff --git a/docs/reference/meson.build b/docs/reference/meson.build
new file mode 100644
index 0000000..b617ba9
--- /dev/null
+++ b/docs/reference/meson.build
@@ -0,0 +1,31 @@
+toml_data = configuration_data()
+toml_data.set('VERSION', meson.project_version())
+
+nautilus_toml = configure_file(
+ input: 'nautilus.toml.in',
+ output: 'nautilus.toml',
+ configuration: toml_data,
+)
+
+custom_target(
+ 'nautilus-doc',
+ input: [
+ nautilus_toml,
+ nautilus_extension_gir[0],
+ ],
+ output: 'nautilus',
+ command: [
+ gi_docgen,
+ 'generate',
+ '--quiet',
+ '--add-include-path=@0@'.format(meson.project_source_root() / 'libnautilus-extension'),
+ '--config=@INPUT0@',
+ '--output-dir=@OUTPUT@',
+ '--no-namespace-dir',
+ '--content-dir=@0@'.format(meson.current_source_dir()),
+ '@INPUT1@',
+ ],
+ build_by_default: true,
+ install: true,
+ install_dir: docdir,
+)
diff --git a/docs/reference/nautilus.toml.in b/docs/reference/nautilus.toml.in
new file mode 100644
index 0000000..1d160ad
--- /dev/null
+++ b/docs/reference/nautilus.toml.in
@@ -0,0 +1,22 @@
+[library]
+version = "@VERSION@"
+description = "Nautilus Extension API"
+license = "GPL-2.0-or-later"
+browse_url = "https://gitlab.gnome.org/GNOME/nautilus/"
+repository_url = "https://gitlab.gnome.org/GNOME/nautilus.git"
+devhelp = true
+search_index = true
+
+[theme]
+name = "basic"
+show_index_summary = true
+show_class_hierarchy = true
+
+[source-location]
+# The base URL for the web UI
+base_url = "https://gitlab.gnome.org/GNOME/nautilus/-/blob/master/"
+# The format for links, using "filename" and "line" for the format
+file_format = "{filename}#L{line}"
+
+[extra]
+urlmap_file = "urlmap.js"
diff --git a/docs/reference/urlmap.js b/docs/reference/urlmap.js
new file mode 100644
index 0000000..84b05c3
--- /dev/null
+++ b/docs/reference/urlmap.js
@@ -0,0 +1,9 @@
+// SPDX-FileCopyrightText: 2021 GNOME Foundation
+// SPDX-License-Identifier: LGPL-2.1-or-later
+
+// A map between namespaces and base URLs for their online documentation
+baseURLs = [
+ ["GLib", "https://docs.gtk.org/glib/"],
+ ["Gio", "https://docs.gtk.org/gio/"],
+ ["GObject", "https://docs.gtk.org/gobject/"],
+];