summaryrefslogtreecommitdiffstats
path: root/po/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:35:18 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:35:18 +0000
commitb750101eb236130cf056c675997decbac904cc49 (patch)
treea5df1a06754bdd014cb975c051c83b01c9a97532 /po/meson.build
parentInitial commit. (diff)
downloadsystemd-b750101eb236130cf056c675997decbac904cc49.tar.xz
systemd-b750101eb236130cf056c675997decbac904cc49.zip
Adding upstream version 252.22.upstream/252.22upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'po/meson.build')
-rw-r--r--po/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/po/meson.build b/po/meson.build
new file mode 100644
index 0000000..0a140b4
--- /dev/null
+++ b/po/meson.build
@@ -0,0 +1,10 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+want_translations = get_option('translations')
+
+if want_translations
+ i18n = import('i18n')
+ i18n.gettext(meson.project_name(),
+ preset : 'glib',
+ data_dirs : '.')
+endif