summaryrefslogtreecommitdiffstats
path: root/build/rust/wasi/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /build/rust/wasi/Cargo.toml
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'build/rust/wasi/Cargo.toml')
-rw-r--r--build/rust/wasi/Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/build/rust/wasi/Cargo.toml b/build/rust/wasi/Cargo.toml
new file mode 100644
index 0000000000..e1f392a961
--- /dev/null
+++ b/build/rust/wasi/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "wasi"
+version = "0.10.0+wasi-snapshot-preview999"
+edition = "2018"
+license = "MPL-2.0"
+
+[lib]
+path = "lib.rs"
+
+[dependencies.wasi]
+version = "0.11"
+default-features = false
+
+[features]
+default = ["wasi/default"]
+rustc-dep-of-std = ["wasi/rustc-dep-of-std"]
+std = ["wasi/std"]