summaryrefslogtreecommitdiffstats
path: root/.vscode/settings.json
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 08:35:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 08:35:51 +0000
commit641d0d615623d4818993e1967fc96af1eefc4605 (patch)
treec40f205eb559c8a495489262190a0be4f1829740 /.vscode/settings.json
parentAdding upstream version 0.13.0. (diff)
downloadanta-641d0d615623d4818993e1967fc96af1eefc4605.tar.xz
anta-641d0d615623d4818993e1967fc96af1eefc4605.zip
Adding upstream version 0.14.0.upstream/0.14.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.vscode/settings.json')
-rw-r--r--.vscode/settings.json18
1 files changed, 4 insertions, 14 deletions
diff --git a/.vscode/settings.json b/.vscode/settings.json
index ff14cc1..8428c00 100644
--- a/.vscode/settings.json
+++ b/.vscode/settings.json
@@ -1,14 +1,8 @@
{
- "black-formatter.importStrategy": "fromEnvironment",
+ "ruff.enable": true,
+ "python.testing.unittestEnabled": false,
+ "python.testing.pytestEnabled": true,
"pylint.importStrategy": "fromEnvironment",
- "pylint.args": [
- "--rcfile=pylintrc"
- ],
- "flake8.importStrategy": "fromEnvironment",
- "flake8.args": [
- "--config=/dev/null",
- "--max-line-length=165"
- ],
"mypy-type-checker.importStrategy": "fromEnvironment",
"mypy-type-checker.args": [
"--config-file=pyproject.toml"
@@ -17,14 +11,10 @@
"refactor": "Warning"
},
"pylint.args": [
- "--load-plugins pylint_pydantic",
+ "--load-plugins", "pylint_pydantic",
"--rcfile=pylintrc"
],
"python.testing.pytestArgs": [
"tests"
],
- "python.testing.unittestEnabled": false,
- "python.testing.pytestEnabled": true,
- "isort.importStrategy": "fromEnvironment",
- "isort.check": true,
} \ No newline at end of file