summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-08-27 02:25:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-08-27 02:32:49 +0000
commit45b68b5e89e82c8237a5b028f7c1596a905f95fe (patch)
treee5d074f2da0bd432f31e1dfb4bffe8100ac90075
parentUpdating to standards version 4.6.0. (diff)
downloadck-45b68b5e89e82c8237a5b028f7c1596a905f95fe.tar.xz
ck-45b68b5e89e82c8237a5b028f7c1596a905f95fe.zip
Fixing baseline violations on armel and i386, thanks to Adrian Bunk <bunk@debian.org> (Closes: #993010).
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/patches/debian/0001-cc-builtins.patch17
-rw-r--r--debian/patches/debian/0002-disable-sse.patch23
-rw-r--r--debian/patches/series2
-rwxr-xr-xdebian/rules10
4 files changed, 49 insertions, 3 deletions
diff --git a/debian/patches/debian/0001-cc-builtins.patch b/debian/patches/debian/0001-cc-builtins.patch
new file mode 100644
index 0000000..0d0cafc
--- /dev/null
+++ b/debian/patches/debian/0001-cc-builtins.patch
@@ -0,0 +1,17 @@
+Author: Adrian Bunk <bunk@debian.org>
+Description: Fix USE_CC_BUILTINS.
+
+diff -Naurp ck.orig/configure ck/configure
+--- ck.orig/configure
++++ ck/configure
+@@ -551,8 +551,8 @@ else
+ fi
+
+ if test "$USE_CC_BUILTINS"; then
+- CFLAGS="$CFLAGS -DCK_CC_BUILTINS"
+- PC_CFLAGS="-DCK_CC_BULITINS"
++ CFLAGS="$CFLAGS -DCK_USE_CC_BUILTINS=1"
++ PC_CFLAGS="-DCK_USE_CC_BUILTINS=1"
+ fi
+
+ # `which` on Solaris sucks
diff --git a/debian/patches/debian/0002-disable-sse.patch b/debian/patches/debian/0002-disable-sse.patch
new file mode 100644
index 0000000..1a19128
--- /dev/null
+++ b/debian/patches/debian/0002-disable-sse.patch
@@ -0,0 +1,23 @@
+Author: Adrian Bunk <bunk@debian.org>
+Description: Don't pass -msse -msse2 with --disable-sse on x86.
+
+diff -Naurp ck.orig/build/ck.build.x86 ck/build/ck.build.x86
+--- ck.orig/build/ck.build.x86
++++ ck/build/ck.build.x86
+@@ -1,2 +1,2 @@
+-CFLAGS+=-m32 -D__x86__ -msse -msse2
++CFLAGS+=-m32 -D__x86__
+ LDFLAGS+=-m32
+diff -Naurp ck.orig/configure ck/configure
+--- ck.orig/configure
++++ ck/configure
+@@ -424,6 +424,9 @@ case $PLATFORM in
+ LDFLAGS="-m64 $LDFLAGS"
+ ;;
+ i386|i486|i586|i686|i586_i686|pentium*|athlon*|k5|k6|k6_2|k6_3)
++ if test "${SSE_DISABLE}" = "CK_MD_SSE_ENABLE"; then
++ CFLAGS="$CFLAGS -msse -msse2"
++ fi
+ LSE_ENABLE="CK_MD_LSE_DISABLE"
+ MM="${MM:-"CK_MD_TSO"}"
+ case $SYSTEM in
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..e1dc10d
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+debian/0001-cc-builtins.patch
+debian/0002-disable-sse.patch
diff --git a/debian/rules b/debian/rules
index ee6a3be..e8da4e2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,8 +2,12 @@
include /usr/share/dpkg/architecture.mk
-ifeq ($(DEB_BUILD_ARCH),armel)
- PLATFORM = --platform=armv7l
+ifneq (,$(filter $(DEB_HOST_ARCH), armel x32))
+ PLATFORM = --platform=unknown
+endif
+
+ifeq ($(DEB_HOST_ARCH), i386)
+ PLATFORM = --disable-sse
endif
%:
@@ -16,7 +20,7 @@ override_dh_auto_configure:
--includedir=/usr/include \
--mandir=/usr/share/man \
--cores=2 \
- --disable-sse $(PLATFORM)
+ $(PLATFORM)
override_dh_auto_test:
$(MAKE) -j1 check