summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2023-12-10 09:44:21 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2023-12-10 09:44:21 +0000
commit02b4498febc720f88a8e823870906edeeb6bb634 (patch)
tree0791516ff428f61312ad3c220ef6af556b3f1f51 /debian
parentReleasing debian version 0.7.1-11. (diff)
downloadck-02b4498febc720f88a8e823870906edeeb6bb634.tar.xz
ck-02b4498febc720f88a8e823870906edeeb6bb634.zip
Skipping tests when building non-parallel to fix hanging test suite, thanks to Santiago Vila <sanvila@debian.org> (Closes: #1055218).
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules8
1 files changed, 8 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 70667c5..e91561b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,6 +15,12 @@ ifeq ($(DEB_HOST_ARCH), i386)
PLATFORM = --disable-sse
endif
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+else
+ NUMJOBS = 1
+endif
+
%:
dh ${@}
@@ -37,5 +43,7 @@ override_dh_auto_configure:
override_dh_auto_test:
ifneq (,$(filter $(DEB_HOST_ARCH), amd64 arm64 i386))
+ifneq ($(NUMJOBS), 1)
$(MAKE) -j1 check
endif
+endif