summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-11-20 08:27:34 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-11-20 08:34:49 +0000
commita1517283f513288e2286a9975c25c26fcf61eabd (patch)
tree9de66e58888efe48f02ef2853305e627e169e188 /debian
parentReleasing debian version 0.7.1-6. (diff)
downloadck-a1517283f513288e2286a9975c25c26fcf61eabd.tar.xz
ck-a1517283f513288e2286a9975c25c26fcf61eabd.zip
WIP MIPS
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules8
1 files changed, 6 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index fc4665d..2e97676 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,6 +6,10 @@ ifneq (,$(filter $(DEB_HOST_ARCH), armel x32))
PLATFORM = --platform=unknown
endif
+ifneq (,$(filter $(DEB_HOST_ARCH), mipsel))
+ PLATFORM = --platform=mips32
+endif
+
ifeq ($(DEB_HOST_ARCH), i386)
PLATFORM = --disable-sse
endif
@@ -23,6 +27,6 @@ override_dh_auto_configure:
$(PLATFORM)
override_dh_auto_test:
-ifneq (,$(filter $(DEB_HOST_ARCH), amd64 arm64 i386))
+#ifneq (,$(filter $(DEB_HOST_ARCH), amd64 arm64 i386))
$(MAKE) -j1 check
-endif
+#endif