summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-12-10 11:13:08 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-12-10 11:13:08 +0000
commit9a5a4b27cb3c911f0c8ea622f183038b409de792 (patch)
treef16fe350773078608d57119ebe950c5d2793db46 /pyproject.toml
parentReleasing debian version 2.1.2~dev0+20230918-1. (diff)
downloaddeluge-9a5a4b27cb3c911f0c8ea622f183038b409de792.tar.xz
deluge-9a5a4b27cb3c911f0c8ea622f183038b409de792.zip
Merging upstream version 2.1.2~dev0+20231127.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml7
1 files changed, 3 insertions, 4 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 0449619..169561f 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,8 +1,5 @@
[build-system]
-requires = [
- "setuptools",
- "wheel",
-]
+requires = ["setuptools", "wheel"]
[tool.black]
skip-string-normalization = true
@@ -11,6 +8,8 @@ skip-string-normalization = true
profile = "black"
[tool.pytest.ini_options]
+# Dump tracebacks if a test takes longer than X seconds
+faulthandler_timeout = 60
# Hide logged warnings and errors in test output.
log_cli_level = "CRITICAL"
addopts = "--basetemp=_pytest_temp"