summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2020-08-18 20:21:46 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2020-08-18 20:21:46 +0000
commitbddee63922e227c73fd1b4e5b50bbef56bb9a61f (patch)
treeee729b4d2250e2935a4922f120637a68ed91db17 /Makefile
parentInitial commit. (diff)
downloadgita-bddee63922e227c73fd1b4e5b50bbef56bb9a61f.tar.xz
gita-bddee63922e227c73fd1b4e5b50bbef56bb9a61f.zip
Adding upstream version 0.10.9.upstream/0.10.9
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..c67d4a7
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,12 @@
+.PHONY: dist test install clean twine
+
+install:
+ pip3 install -e .
+test: clean
+ pytest tests --cov=./gita $(TEST_ARGS) -n=auto
+dist: clean
+ python3 setup.py sdist
+twine:
+ twine upload dist/*
+clean:
+ git clean -fdx