summaryrefslogtreecommitdiffstats
path: root/identify
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-03-11 08:04:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-03-11 08:04:52 +0000
commit508fc0b8207092855dd53ebbb42852ddfb92c6f7 (patch)
tree1884a67d422ea936a57693a10de3734f35c8348b /identify
parentReleasing debian version 2.5.18-1. (diff)
downloadidentify-508fc0b8207092855dd53ebbb42852ddfb92c6f7.tar.xz
identify-508fc0b8207092855dd53ebbb42852ddfb92c6f7.zip
Merging upstream version 2.5.19.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'identify')
-rw-r--r--identify/extensions.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/identify/extensions.py b/identify/extensions.py
index 6addba6..dae7d2d 100644
--- a/identify/extensions.py
+++ b/identify/extensions.py
@@ -171,6 +171,7 @@ EXTENSIONS = {
'pm': {'text', 'perl'},
'png': {'binary', 'image', 'png'},
'po': {'text', 'pofile'},
+ 'pom': {'pom', 'text', 'xml'},
'pp': {'text', 'puppet'},
'prisma': {'text', 'prisma'},
'properties': {'text', 'java-properties'},
@@ -345,6 +346,7 @@ NAMES = {
'Pipfile.lock': EXTENSIONS['json'],
'PKGBUILD': {'text', 'bash', 'pkgbuild', 'alpm'},
'poetry.lock': EXTENSIONS['toml'],
+ 'pom.xml': EXTENSIONS['pom'],
'pylintrc': EXTENSIONS['ini'] | {'pylintrc'},
'README': EXTENSIONS['txt'],
'Rakefile': EXTENSIONS['rb'],