summaryrefslogtreecommitdiffstats
path: root/Dockerfile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2020-03-21 10:28:17 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-02-07 11:16:53 +0000
commit06cba6ccd165ca8b224797e37fccb9e63f026d77 (patch)
treee82f1bc439997ae296f2e74f8a64d84c5d95f140 /Dockerfile
parentInitial commit. (diff)
downloadiredis-06cba6ccd165ca8b224797e37fccb9e63f026d77.tar.xz
iredis-06cba6ccd165ca8b224797e37fccb9e63f026d77.zip
Adding upstream version 1.9.1.upstream/1.9.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Dockerfile')
-rw-r--r--Dockerfile18
1 files changed, 18 insertions, 0 deletions
diff --git a/Dockerfile b/Dockerfile
new file mode 100644
index 0000000..99c0463
--- /dev/null
+++ b/Dockerfile
@@ -0,0 +1,18 @@
+FROM python:3
+
+WORKDIR /iredis
+COPY README.md poetry.lock pyproject.toml ./
+COPY iredis ./iredis
+
+RUN apt-get update && apt-get install -y --allow-unauthenticated \
+ redis-server && \
+ rm -rf /var/lib/apt/lists/*
+
+
+RUN python3 -m venv iredis_env && \
+ . iredis_env/bin/activate && \
+ pip install poetry && \
+ poetry install --no-dev && \
+ rm -rf ~/.cache
+
+CMD ["sh","-c","redis-server --daemonize yes && . iredis_env/bin/activate && iredis"]