summaryrefslogtreecommitdiffstats
path: root/Dockerfile
diff options
context:
space:
mode:
Diffstat (limited to 'Dockerfile')
-rw-r--r--Dockerfile18
1 files changed, 18 insertions, 0 deletions
diff --git a/Dockerfile b/Dockerfile
new file mode 100644
index 0000000..99c0463
--- /dev/null
+++ b/Dockerfile
@@ -0,0 +1,18 @@
+FROM python:3
+
+WORKDIR /iredis
+COPY README.md poetry.lock pyproject.toml ./
+COPY iredis ./iredis
+
+RUN apt-get update && apt-get install -y --allow-unauthenticated \
+ redis-server && \
+ rm -rf /var/lib/apt/lists/*
+
+
+RUN python3 -m venv iredis_env && \
+ . iredis_env/bin/activate && \
+ pip install poetry && \
+ poetry install --no-dev && \
+ rm -rf ~/.cache
+
+CMD ["sh","-c","redis-server --daemonize yes && . iredis_env/bin/activate && iredis"]