summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2017-10-17 13:11:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2017-10-17 13:11:40 +0000
commit84de00e9a0eb06d8473e5677aec1e6c297268a43 (patch)
tree8388657f9dac0c54a00dfc6fb36fb350bd166b5f
parentDeprecating priority extra as of policy 4.0.1. (diff)
downloadlzlib-84de00e9a0eb06d8473e5677aec1e6c297268a43.tar.xz
lzlib-84de00e9a0eb06d8473e5677aec1e6c297268a43.zip
Applying patch from Helmut Grohne <helmut@subdivi.de> to fix FTBFS when cross-compiling (Closes: #871605).
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rwxr-xr-xdebian/rules8
1 files changed, 6 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 6057e7c..9a92972 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,16 @@
#!/usr/bin/make -f
-DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+include /usr/share/dpkg/architecture.mk
+
+ifeq ($(origin CC),default)
+CC = $(DEB_HOST_GNU_TYPE)-gcc
+endif
%:
dh ${@}
override_dh_auto_configure:
- dh_auto_configure -- --enable-shared --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH)
+ dh_auto_configure -- --enable-shared --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) 'CC=$(CC)'
override_dh_auto_install:
dh_auto_install -- LDCONFIG=/bin/true