summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 2 insertions, 14 deletions
diff --git a/debian/rules b/debian/rules
index 80c7431..8451ed8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,24 +1,12 @@
#!/usr/bin/make -f
-SHELL := sh -e
-
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
%:
dh ${@}
-override_dh_auto_clean:
- dh_auto_clean
-
- for _FILE in debian/*.install.in; \
- do \
- rm -f debian/$$(basename $${_FILE} .in); \
- sed -e 's|@DEB_HOST_MULTIARCH@|$(DEB_HOST_MULTIARCH)|g' \
- $${_FILE} > debian/$$(basename $${_FILE} .in); \
- done
-
override_dh_auto_configure:
- dh_auto_configure -- --enable-shared --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH)
+ dh_auto_configure -- --enable-shared --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) CFLAGS="$(CFLAGS CPPFLAGS)" LDFLAGS="$(LDFLAGS)"
override_dh_auto_install:
dh_auto_install -- LDCONFIG=/bin/true
@@ -34,7 +22,7 @@ endif
rm -f debian/tmp/usr/share/info/dir*
override_dh_builddeb:
- dh_builddeb -- -Zgzip -z9
+ dh_builddeb -- -Zxz -z9
override_dh_gencontrol:
ifeq ($(DEB_HOST_MULTIARCH),)