summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-03-08 06:40:40 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-03-08 06:40:49 +0000
commit009d0b0f17cc82919a683a1ecb6a334f5354090d (patch)
treea892178f3bfd61e0f42ccb31c17d54165d370ae9 /setup.py
parentReleasing debian version 1.23.2-2. (diff)
downloadmycli-009d0b0f17cc82919a683a1ecb6a334f5354090d.tar.xz
mycli-009d0b0f17cc82919a683a1ecb6a334f5354090d.zip
Merging upstream version 1.24.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 6 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 4aa7f91..1d619f3 100755
--- a/setup.py
+++ b/setup.py
@@ -18,16 +18,20 @@ description = 'CLI for MySQL Database. With auto-completion and syntax highlight
install_requirements = [
'click >= 7.0',
+ 'cryptography >= 1.0.0',
'Pygments >= 1.6',
'prompt_toolkit>=3.0.6,<4.0.0',
'PyMySQL >= 0.9.2',
'sqlparse>=0.3.0,<0.4.0',
'configobj >= 5.0.5',
- 'cryptography >= 1.0.0',
'cli_helpers[styles] >= 2.0.1',
- 'pyperclip >= 1.8.1'
+ 'pyperclip >= 1.8.1',
+ 'pyaes >= 1.6.1'
]
+if sys.version_info.minor < 9:
+ install_requirements.append('importlib_resources >= 5.0.0')
+
class lint(Command):
description = 'check code against PEP 8 (and fix violations)'