summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 6 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 4aa7f91..1d619f3 100755
--- a/setup.py
+++ b/setup.py
@@ -18,16 +18,20 @@ description = 'CLI for MySQL Database. With auto-completion and syntax highlight
install_requirements = [
'click >= 7.0',
+ 'cryptography >= 1.0.0',
'Pygments >= 1.6',
'prompt_toolkit>=3.0.6,<4.0.0',
'PyMySQL >= 0.9.2',
'sqlparse>=0.3.0,<0.4.0',
'configobj >= 5.0.5',
- 'cryptography >= 1.0.0',
'cli_helpers[styles] >= 2.0.1',
- 'pyperclip >= 1.8.1'
+ 'pyperclip >= 1.8.1',
+ 'pyaes >= 1.6.1'
]
+if sys.version_info.minor < 9:
+ install_requirements.append('importlib_resources >= 5.0.0')
+
class lint(Command):
description = 'check code against PEP 8 (and fix violations)'