summaryrefslogtreecommitdiffstats
path: root/contrib/debian
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-04-14 18:12:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-04-14 18:12:14 +0000
commitbb50acdcb8073654ea667b8c0272e335bd43f844 (patch)
tree1e00c8a29871426f8182658928dcb62e42d57ce8 /contrib/debian
parentReleasing debian version 1.33.1-1. (diff)
downloadnetdata-bb50acdcb8073654ea667b8c0272e335bd43f844.tar.xz
netdata-bb50acdcb8073654ea667b8c0272e335bd43f844.zip
Merging upstream version 1.34.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'contrib/debian')
-rw-r--r--contrib/debian/compat2
-rw-r--r--contrib/debian/netdata.postinst3
-rwxr-xr-xcontrib/debian/rules20
3 files changed, 13 insertions, 12 deletions
diff --git a/contrib/debian/compat b/contrib/debian/compat
index ec635144f..f599e28b8 100644
--- a/contrib/debian/compat
+++ b/contrib/debian/compat
@@ -1 +1 @@
-9
+10
diff --git a/contrib/debian/netdata.postinst b/contrib/debian/netdata.postinst
index f26c94f93..a6bd29960 100644
--- a/contrib/debian/netdata.postinst
+++ b/contrib/debian/netdata.postinst
@@ -50,9 +50,7 @@ case "$1" in
dpkg-statoverride --force --update --add root netdata 0775 /var/lib/netdata/registry > /dev/null 2>&1
- chown -R root:netdata /usr/share/netdata
chown -R root:netdata /usr/libexec/netdata/plugins.d
- chown -R root:netdata /var/lib/netdata/www
setcap cap_dac_read_search,cap_sys_ptrace+ep /usr/libexec/netdata/plugins.d/apps.plugin
setcap cap_dac_read_search+ep /usr/libexec/netdata/plugins.d/slabinfo.plugin
capsh --supports=cap_perfmon 2>/dev/null && setcap cap_perfmon+ep /usr/libexec/netdata/plugins.d/perf.plugin || setcap cap_sys_admin+ep /usr/libexec/netdata/plugins.d/perf.plugin
@@ -65,6 +63,7 @@ case "$1" in
# Workaround for other plugins not installed directly by this package
chmod -f 4750 /usr/libexec/netdata/plugins.d/freeipmi.plugin || true
+ chmod -f 4750 /usr/libexec/netdata/plugins.d/ioping || true
;;
esac
diff --git a/contrib/debian/rules b/contrib/debian/rules
index f36e995fc..cbf4a8375 100755
--- a/contrib/debian/rules
+++ b/contrib/debian/rules
@@ -23,26 +23,20 @@ HAVE_EBPF = 1
endif
%:
- # For jessie and beyond
- #
- dh $@ --with autoreconf,systemd
-
- # For wheezy or other non-systemd distributions use the following. You
- # should also see contrib/README.md which gives details of updates to
- # make to debian/control.
- #
- #dh $@ --with autoreconf
+ dh $@
override_dh_installinit:
echo "SystemD Version: $(SYSTEMD_VERSION)"
echo "Using SystemD Unit: $(SYSTEMD_UNIT)"
cp -v $(SYSTEMD_UNIT) debian/netdata.service
+ dh_systemd_enable
dh_installinit
override_dh_auto_configure:
if [ $(HAVE_EBPF) -eq 1 ]; then \
packaging/bundle-libbpf.sh . ${TOP}/usr/libexec/netdata/plugins.d; \
+ packaging/bundle-ebpf-co-re.sh . ${TOP}/usr/libexec/netdata/plugins.d; \
fi
autoreconf -ivf
dh_auto_configure -- --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libdir=/usr/lib \
@@ -75,6 +69,10 @@ override_dh_install:
mkdir -p "$(TOP)/var/cache/netdata"
mkdir -p "$(TOP)/var/run/netdata"
+ # Copy the updater script
+ #
+ cp -v packaging/installer/netdata-updater.sh $(TOP)/usr/libexec/netdata/netdata-updater.sh
+
# Move files that local user shouldn't be editing to /usr/share/netdata
#
mkdir -p "$(TOP)/usr/share/netdata/www"
@@ -108,6 +106,10 @@ override_dh_installdocs:
override_dh_fixperms:
dh_fixperms
+ # Updater script should be executable
+ #
+ chmod 0755 $(TOP)/usr/libexec/netdata/netdata-updater.sh
+
# apps.plugin should only be runnable by the netdata user. It will be
# given extra capabilities in the postinst script.
#