summaryrefslogtreecommitdiffstats
path: root/Documentation/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-07-26 05:11:40 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-07-26 05:18:07 +0000
commit2e650c1f5f2f79e7db10dec5dcdd1cffcaf47891 (patch)
tree82f2949088d2502e947b83ba9973de54f9bf4402 /Documentation/meson.build
parentReleasing debian version 2.0-1. (diff)
downloadnvme-cli-2e650c1f5f2f79e7db10dec5dcdd1cffcaf47891.tar.xz
nvme-cli-2e650c1f5f2f79e7db10dec5dcdd1cffcaf47891.zip
Merging upstream version 2.1~rc0 (Closes: #1015722).
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Documentation/meson.build')
-rw-r--r--Documentation/meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/Documentation/meson.build b/Documentation/meson.build
index a12eec4..a47c27f 100644
--- a/Documentation/meson.build
+++ b/Documentation/meson.build
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
adoc_sources = [
'nvme',
'nvme-admin-passthru',
@@ -114,6 +116,7 @@ adoc_sources = [
'nvme-wdc-clear-assert-dump',
'nvme-wdc-clear-fw-activate-history',
'nvme-wdc-clear-pcie-correctable-errors',
+ 'nvme-wdc-cloud-boot-SSD-version',
'nvme-wdc-cloud-SSD-plugin-version',
'nvme-wdc-drive-essentials',
'nvme-wdc-drive-log',
@@ -131,9 +134,12 @@ adoc_sources = [
'nvme-wdc-namespace-resize',
'nvme-wdc-purge',
'nvme-wdc-purge-monitor',
+ 'nvme-wdc-vs-cloud-log',
+ 'nvme-wdc-vs-device-waf',
'nvme-wdc-vs-drive-info',
'nvme-wdc-vs-error-reason-identifier',
'nvme-wdc-vs-fw-activate-history',
+ 'nvme-wdc-vs-hw-rev-log',
'nvme-wdc-vs-internal-log',
'nvme-wdc-vs-nand-stats',
'nvme-wdc-vs-smart-add-log',
@@ -168,7 +174,7 @@ if want_docs != 'false'
mandir = join_paths(get_option('mandir'), 'man1')
htmldir = join_paths(get_option('htmldir'), 'nvme')
- asciidoctor = find_program('asciidoc', required : false)
+ asciidoctor = find_program('asciidoc', required: get_option('docs-build'))
if want_docs_build and asciidoctor.found()
# Build documentation before installing