summaryrefslogtreecommitdiffstats
path: root/Documentation/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'Documentation/meson.build')
-rw-r--r--Documentation/meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/Documentation/meson.build b/Documentation/meson.build
index a12eec4..a47c27f 100644
--- a/Documentation/meson.build
+++ b/Documentation/meson.build
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
adoc_sources = [
'nvme',
'nvme-admin-passthru',
@@ -114,6 +116,7 @@ adoc_sources = [
'nvme-wdc-clear-assert-dump',
'nvme-wdc-clear-fw-activate-history',
'nvme-wdc-clear-pcie-correctable-errors',
+ 'nvme-wdc-cloud-boot-SSD-version',
'nvme-wdc-cloud-SSD-plugin-version',
'nvme-wdc-drive-essentials',
'nvme-wdc-drive-log',
@@ -131,9 +134,12 @@ adoc_sources = [
'nvme-wdc-namespace-resize',
'nvme-wdc-purge',
'nvme-wdc-purge-monitor',
+ 'nvme-wdc-vs-cloud-log',
+ 'nvme-wdc-vs-device-waf',
'nvme-wdc-vs-drive-info',
'nvme-wdc-vs-error-reason-identifier',
'nvme-wdc-vs-fw-activate-history',
+ 'nvme-wdc-vs-hw-rev-log',
'nvme-wdc-vs-internal-log',
'nvme-wdc-vs-nand-stats',
'nvme-wdc-vs-smart-add-log',
@@ -168,7 +174,7 @@ if want_docs != 'false'
mandir = join_paths(get_option('mandir'), 'man1')
htmldir = join_paths(get_option('htmldir'), 'nvme')
- asciidoctor = find_program('asciidoc', required : false)
+ asciidoctor = find_program('asciidoc', required: get_option('docs-build'))
if want_docs_build and asciidoctor.found()
# Build documentation before installing