summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2019-02-02 08:45:45 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2019-02-02 08:58:31 +0000
commitc63767cdee7fb4fcf625ec57b6cd6360ef82bdbb (patch)
tree635d2045cba6d19ac488c2b12601f899534276e0 /debian/rules
parentRepeating Section for binary packages in control. (diff)
downloadopen-infrastructure-storage-tools-c63767cdee7fb4fcf625ec57b6cd6360ef82bdbb.tar.xz
open-infrastructure-storage-tools-c63767cdee7fb4fcf625ec57b6cd6360ef82bdbb.zip
Renaming binary package to open-infrastructure-ceph-tools for consistency and future-proofing.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 5 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 0257615..595bf6d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,6 @@
#!/usr/bin/make -f
-PACKAGE := storage-tools
+PACKAGE := ceph-tools
%:
dh ${@} --with apache2
@@ -9,12 +9,12 @@ override_dh_auto_build:
# disabled
override_dh_auto_install:
- dh_auto_install
+ dh_auto_install -- DESTDIR=$(CURDIR)/debian/open-infrastructure-ceph-tools
- rm -f debian/open-infrastructure-$(PACKAGE)/usr/share/doc/$(PACKAGE)/CHANGELOG.txt
- rm -f debian/open-infrastructure-$(PACKAGE)/usr/share/doc/$(PACKAGE)/LICENSE.txt
+ rm -f debian/open-infrastructure-$(PACKAGE)/usr/share/doc/storage-tools/CHANGELOG.txt
+ rm -f debian/open-infrastructure-$(PACKAGE)/usr/share/doc/storage-tools/LICENSE.txt
- mv debian/open-infrastructure-$(PACKAGE)/usr/share/doc/$(PACKAGE) debian/open-infrastructure-$(PACKAGE)/usr/share/doc/open-infrastructure-$(PACKAGE)
+ mv debian/open-infrastructure-$(PACKAGE)/usr/share/doc/storage-tools debian/open-infrastructure-$(PACKAGE)/usr/share/doc/open-infrastructure-$(PACKAGE)
override_dh_systemd_enable:
dh_systemd_enable --name=ceph-log