summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 9ff25db..fd6340e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,6 @@
#!/usr/bin/make -f
--include /usr/share/dpkg/buildtools.mk
+include /usr/share/dpkg/buildtools.mk
%:
dh ${@}
@@ -11,9 +11,13 @@ override_dh_auto_configure:
override_dh_auto_install:
dh_auto_install -- DESTDIR=$(CURDIR)/debian/pdlzip
+execute_after_dh_auto_install:
# update-alternatives
mv debian/pdlzip/usr/bin/pdlzip debian/pdlzip/usr/bin/lzip.pdlzip
ln -s /usr/bin/lzip.pdlzip debian/pdlzip/usr/bin/pdlzip
mv debian/pdlzip/usr/share/man/man1/pdlzip.1 debian/pdlzip/usr/share/man/man1/lzip.pdlzip.1
ln -s /usr/share/man/man1/lzip.pdlzip.1.gz debian/pdlzip/usr/share/man/man1/pdlzip.1.gz
+
+override_dh_auto_test:
+ # disabled: incomplete upstream testsuite