summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-02-07 07:34:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-02-07 07:50:21 +0000
commitfe534d5229de5e83dccdfa3e4ba3c1b29bd38a71 (patch)
treeb6c5cd613e258116b1f732732c78f87b3d5f6e50 /pyproject.toml
parentInitial commit. (diff)
downloadpytzdata-fe534d5229de5e83dccdfa3e4ba3c1b29bd38a71.tar.xz
pytzdata-fe534d5229de5e83dccdfa3e4ba3c1b29bd38a71.zip
Adding upstream version 2020.1+dfsg.upstream/2010.1+dfsgupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml34
1 files changed, 34 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..975111d
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,34 @@
+[tool.poetry]
+name = "pytzdata"
+version = "2020.1"
+description = "The Olson timezone database for Python."
+authors = [
+ "Sébastien Eustace <sebastien@eustace.io>"
+]
+license = "MIT"
+
+readme = "README.rst"
+
+homepage = "https://github.com/sdispater/pytzdata"
+repository = "https://github.com/sdispater/pytzdata"
+
+classifiers = [
+ "Operating System :: OS Independent",
+ "Topic :: Software Development :: Libraries :: Python Modules"
+]
+
+[tool.poetry.dependencies]
+python = "~2.7 || ^3.4"
+
+
+[tool.poetry.dev-dependencies]
+autopep8 = "^1.3"
+cleo = "^0.6.5"
+pytest = "^3.5"
+tox = "^3.0"
+black = {version = "^19.10b0", python = "^3.6"}
+
+
+[build-system]
+requires = ["poetry>=1.0.0"]
+build-backend = "poetry.masonry.api"