summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml34
1 files changed, 34 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..975111d
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,34 @@
+[tool.poetry]
+name = "pytzdata"
+version = "2020.1"
+description = "The Olson timezone database for Python."
+authors = [
+ "Sébastien Eustace <sebastien@eustace.io>"
+]
+license = "MIT"
+
+readme = "README.rst"
+
+homepage = "https://github.com/sdispater/pytzdata"
+repository = "https://github.com/sdispater/pytzdata"
+
+classifiers = [
+ "Operating System :: OS Independent",
+ "Topic :: Software Development :: Libraries :: Python Modules"
+]
+
+[tool.poetry.dependencies]
+python = "~2.7 || ^3.4"
+
+
+[tool.poetry.dev-dependencies]
+autopep8 = "^1.3"
+cleo = "^0.6.5"
+pytest = "^3.5"
+tox = "^3.0"
+black = {version = "^19.10b0", python = "^3.6"}
+
+
+[build-system]
+requires = ["poetry>=1.0.0"]
+build-backend = "poetry.masonry.api"