summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-01-04 07:24:08 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-01-04 07:24:08 +0000
commit7a2201963d5b03bd1828d350ccaecb4eda30d30c (patch)
tree19effbe90b8d78fdcb5f7d4bd0dd46b177ffdaab /Makefile
parentReleasing debian version 10.2.9-1. (diff)
downloadsqlglot-7a2201963d5b03bd1828d350ccaecb4eda30d30c.tar.xz
sqlglot-7a2201963d5b03bd1828d350ccaecb4eda30d30c.zip
Merging upstream version 10.4.2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..2da2493
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,24 @@
+.PHONY: install install-dev install-pre-commit test style check docs docs-serve
+
+install:
+ pip install -e .
+
+install-dev:
+ pip install -e ".[dev]"
+
+install-pre-commit:
+ pre-commit install
+
+test:
+ python -m unittest
+
+style:
+ pre-commit run --all-files
+
+check: style test
+
+docs:
+ pdoc/cli.py -o pdoc/docs
+
+docs-serve:
+ pdoc/cli.py