summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..2da2493
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,24 @@
+.PHONY: install install-dev install-pre-commit test style check docs docs-serve
+
+install:
+ pip install -e .
+
+install-dev:
+ pip install -e ".[dev]"
+
+install-pre-commit:
+ pre-commit install
+
+test:
+ python -m unittest
+
+style:
+ pre-commit run --all-files
+
+check: style test
+
+docs:
+ pdoc/cli.py -o pdoc/docs
+
+docs-serve:
+ pdoc/cli.py