summaryrefslogtreecommitdiffstats
path: root/debian/control
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 04:09:47 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 04:09:47 +0000
commitb0b8b74c04e6b33a6520a97cbbab2fe2b7f349ae (patch)
tree12089dbf61f9a19a50e9a2dd0c8a42a61da57b18 /debian/control
parentMerging debian version 1.73.0+dfsg1-1. (diff)
downloadrustc-b0b8b74c04e6b33a6520a97cbbab2fe2b7f349ae.tar.xz
rustc-b0b8b74c04e6b33a6520a97cbbab2fe2b7f349ae.zip
Building with llvm-toolchain-16 instead of llvm-toolchain-17.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control18
1 files changed, 9 insertions, 9 deletions
diff --git a/debian/control b/debian/control
index b7bbc418e..907ceb62b 100644
--- a/debian/control
+++ b/debian/control
@@ -19,12 +19,12 @@ Build-Depends:
cargo:native (>= 1.72.0+dfsg) <!pkg.rustc.dlstage0>,
rustc:native (>= 1.72.0+dfsg) <!pkg.rustc.dlstage0>,
rustc:native (<= 1.73.0++) <!pkg.rustc.dlstage0>,
- llvm-17-dev:native,
- llvm-17-tools:native,
+ llvm-16-dev:native,
+ llvm-16-tools:native,
gcc-mingw-w64-x86-64-posix:native [amd64] <!nowindows>,
gcc-mingw-w64-i686-posix:native [i386] <!nowindows>,
- libllvm17t64 (>= 1:17.0.0),
- libclang-rt-17-dev:native,
+ libllvm16 (>= 1:16.0.0),
+ libclang-rt-16-dev:native,
cmake (>= 3.0),
# needed by some vendor crates
pkgconf,
@@ -54,7 +54,7 @@ Build-Depends:
Build-Depends-Indep:
wasi-libc (>= 0.0~git20230821.ec4566b~~) <!nowasm>,
wasi-libc (<= 0.0~git20230821.ec4566b++) <!nowasm>,
- clang-17:native,
+ clang-16:native,
Build-Conflicts: gdb-minimal <!nocheck>
Standards-Version: 4.6.2
Homepage: http://www.rust-lang.org/
@@ -168,7 +168,7 @@ Depends: ${shlibs:Depends}, ${misc:Depends}
# Embeds wasi-libc so doesn't need to depend on it
# None of its licenses require source redistrib, so no need for Built-Using
Recommends:
- lld-17, clang-17,
+ lld-16, clang-16,
Suggests:
# nodejs contains wasi-node for running the program
nodejs (>= 12.16),
@@ -214,7 +214,7 @@ Description: Rust debugger (gdb)
Package: rust-lldb
Architecture: all
# When updating, also update rust-lldb.links
-Depends: lldb-17, ${misc:Depends}, python3-lldb-17
+Depends: lldb-16, ${misc:Depends}, python3-lldb-16
Replaces: rustc (<< 1.1.0+dfsg1-1)
Description: Rust debugger (lldb)
Rust is a curly-brace, block-structured expression language. It
@@ -245,9 +245,9 @@ Replaces:
Depends:
${misc:Depends},
# lld and clang are needed for wasm compilation
- lld-17, clang-17,
+ lld-16, clang-16,
# llvm is needed for llvm-dwp for split-debuginfo=packed
- llvm-17
+ llvm-16
Description: Rust LLVM integration
Rust is a curly-brace, block-structured expression language. It
visually resembles the C language family, but differs significantly