summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2015-11-07 13:46:37 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2015-11-07 13:46:37 +0000
commitdb6c3c269d8bddd9c9c44442d5e1b205083c3093 (patch)
tree11d99c167841709bab5fc0169832ca435492e4ee
parentAdding debian version 1.3-1. (diff)
downloadlzlib-debian-wheezy.tar.xz
lzlib-debian-wheezy.zip
Adding debian version 1.3-2.debian/1.3-2debian-wheezy
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
-rw-r--r--debian/changelog10
-rw-r--r--debian/copyright10
-rwxr-xr-x[-rw-r--r--]debian/liblz-dev.install12
-rw-r--r--debian/liblz-dev.install.in4
-rwxr-xr-x[-rw-r--r--]debian/liblz1.install10
-rw-r--r--debian/liblz1.install.in1
-rw-r--r--debian/patches/01-build.patch19
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules16
-rw-r--r--debian/source/options2
10 files changed, 57 insertions, 28 deletions
diff --git a/debian/changelog b/debian/changelog
index eea032a..ccff777 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+lzlib (1.3-2) unstable; urgency=low
+
+ * Adding patch to avoid overwriting build-environment.
+ * Switching to xz compression.
+ * Makging some editorial changes to copyright file.
+ * Simplyfing backports compatible use of multiarch debhelper install
+ files.
+
+ -- Daniel Baumann <daniel.baumann@progress-technologies.net> Sat, 30 Jun 2012 01:10:35 +0200
+
lzlib (1.3-1) unstable; urgency=low
* Merging upstream version 1.3.
diff --git a/debian/copyright b/debian/copyright
index 02cd0e9..c16d6f2 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -4,15 +4,15 @@ Upstream-Contact: lzip-bug@nongnu.org
Source: http://download.savannah.gnu.org/releases/lzip/
Files: *
-Copyright: (C) 2006-2012 Antonio Diaz Diaz <ant_diaz@teleline.es>
+Copyright: 2006-2012 Antonio Diaz Diaz <ant_diaz@teleline.es>
License: GPL-3+
Files: arg_parser.*
-Copyright: (C) 2006-2012 Antonio Diaz Diaz <ant_diaz@teleline.es>
-License: GPL-3+ with exception
+Copyright: 2006-2012 Antonio Diaz Diaz <ant_diaz@teleline.es>
+License: GPL-3+ with Library exception
Files: debian/*
-Copyright: (C) 2009-2012 Daniel Baumann <daniel.baumann@progress-technologies.net>
+Copyright: 2009-2012 Daniel Baumann <daniel.baumann@progress-technologies.net>
License: GPL-3+
License: GPL-3+
@@ -32,7 +32,7 @@ License: GPL-3+
The complete text of the GNU General Public License
can be found in /usr/share/common-licenses/GPL-3 file.
-License: GPL-3+ with exception
+License: GPL-3+ with Library exception
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
diff --git a/debian/liblz-dev.install b/debian/liblz-dev.install
index 3873b2b..a82be7b 100644..100755
--- a/debian/liblz-dev.install
+++ b/debian/liblz-dev.install
@@ -1,4 +1,12 @@
+#!/bin/sh
+
+set -e
+
+DEB_HOST_MULTIARCH="$(dpkg-architecture -qDEB_HOST_MULTIARCH)"
+
+cat << EOF
usr/include
-usr/lib/i386-linux-gnu/*.a
-usr/lib/i386-linux-gnu/*.so
+usr/lib/${DEB_HOST_MULTIARCH}/*.a
+usr/lib/${DEB_HOST_MULTIARCH}/*.so
usr/share/info
+EOF
diff --git a/debian/liblz-dev.install.in b/debian/liblz-dev.install.in
deleted file mode 100644
index f7bb199..0000000
--- a/debian/liblz-dev.install.in
+++ /dev/null
@@ -1,4 +0,0 @@
-usr/include
-usr/lib/@DEB_HOST_MULTIARCH@/*.a
-usr/lib/@DEB_HOST_MULTIARCH@/*.so
-usr/share/info
diff --git a/debian/liblz1.install b/debian/liblz1.install
index 2b7a24e..68a9cf4 100644..100755
--- a/debian/liblz1.install
+++ b/debian/liblz1.install
@@ -1 +1,9 @@
-usr/lib/i386-linux-gnu/*.so.*
+#!/bin/sh
+
+set -e
+
+DEB_HOST_MULTIARCH="$(dpkg-architecture -qDEB_HOST_MULTIARCH)"
+
+cat << EOF
+usr/lib/${DEB_HOST_MULTIARCH}/*.so.*
+EOF
diff --git a/debian/liblz1.install.in b/debian/liblz1.install.in
deleted file mode 100644
index 8d0a62e..0000000
--- a/debian/liblz1.install.in
+++ /dev/null
@@ -1 +0,0 @@
-usr/lib/@DEB_HOST_MULTIARCH@/*.so.*
diff --git a/debian/patches/01-build.patch b/debian/patches/01-build.patch
new file mode 100644
index 0000000..9b71355
--- /dev/null
+++ b/debian/patches/01-build.patch
@@ -0,0 +1,19 @@
+Author: Daniel Baumann <daniel.baumann@progress-technologies.net>
+Description: Avoid overwriting build-environment.
+
+diff -Naurp lzlib.orig/configure lzlib/configure
+--- lzlib.orig/configure 2012-06-27 16:05:12.182145257 +0200
++++ lzlib/configure 2012-06-30 01:12:33.017869646 +0200
+@@ -28,9 +28,9 @@ infodir='$(datarootdir)/info'
+ libdir='$(exec_prefix)/lib'
+ mandir='$(datarootdir)/man'
+ CC=
+-CPPFLAGS=
+-CFLAGS='-Wall -W -O2'
+-LDFLAGS=
++#CPPFLAGS=
++#CFLAGS='-Wall -W -O2'
++#LDFLAGS=
+
+ # Loop over all args
+ while [ -n "$1" ] ; do
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..605653d
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+01-build.patch
diff --git a/debian/rules b/debian/rules
index 80c7431..8451ed8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,24 +1,12 @@
#!/usr/bin/make -f
-SHELL := sh -e
-
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
%:
dh ${@}
-override_dh_auto_clean:
- dh_auto_clean
-
- for _FILE in debian/*.install.in; \
- do \
- rm -f debian/$$(basename $${_FILE} .in); \
- sed -e 's|@DEB_HOST_MULTIARCH@|$(DEB_HOST_MULTIARCH)|g' \
- $${_FILE} > debian/$$(basename $${_FILE} .in); \
- done
-
override_dh_auto_configure:
- dh_auto_configure -- --enable-shared --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH)
+ dh_auto_configure -- --enable-shared --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) CFLAGS="$(CFLAGS CPPFLAGS)" LDFLAGS="$(LDFLAGS)"
override_dh_auto_install:
dh_auto_install -- LDCONFIG=/bin/true
@@ -34,7 +22,7 @@ endif
rm -f debian/tmp/usr/share/info/dir*
override_dh_builddeb:
- dh_builddeb -- -Zgzip -z9
+ dh_builddeb -- -Zxz -z9
override_dh_gencontrol:
ifeq ($(DEB_HOST_MULTIARCH),)
diff --git a/debian/source/options b/debian/source/options
index d053b65..22a4de9 100644
--- a/debian/source/options
+++ b/debian/source/options
@@ -1,2 +1,2 @@
-compression = gzip
+compression = xz
compression-level = 9